using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<STATUS>.*)\s+(?<expity_date>\d+-\w+-\d+)";
string input = @"EXPIRED & LOCKED 28-SEP-11
LOCKED";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}