package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?<STATUS>.*)\s+(?<expity_date>\d+-\w+-\d+)`)
var str = `EXPIRED & LOCKED 28-SEP-11
LOCKED`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}