// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?<STATUS>.*)\s+(?<expity_date>\d+-\w+-\d+)").unwrap();
let string = "EXPIRED & LOCKED 28-SEP-11
LOCKED";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}