re = /(?<STATUS>.*)\s+(?<expity_date>\d+-\w+-\d+)/m
str = 'EXPIRED & LOCKED 28-SEP-11
LOCKED'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end