$re = '/(?<STATUS>.*)\s+(?<expity_date>\d+-\w+-\d+)/m';
$str = 'EXPIRED & LOCKED 28-SEP-11
LOCKED';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);