#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "ENTITY(?:.*\r?\n)*?.*\((.*)\)"
Local $sString = "ENTITY first" & @CRLF & _
" VHDL language standard: 3 (VHDL-2008)" & @CRLF & _
" ARCHITECTURE BODY arch" & @CRLF & _
" VHDL language standard: 3 (VHDL-2008)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")