package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`ENTITY(?:.*\r?\n)*?.*\((.*)\)`)
var str = `ENTITY first
VHDL language standard: 3 (VHDL-2008)
ARCHITECTURE BODY arch
VHDL language standard: 3 (VHDL-2008)`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}