re = /ENTITY(?:.*\r?\n)*?.*\((.*)\)/
str = 'ENTITY first
VHDL language standard: 3 (VHDL-2008)
ARCHITECTURE BODY arch
VHDL language standard: 3 (VHDL-2008)'
# Print the match result
str.match(re) do |match|
puts match.to_s
end