import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "ENTITY(?:.*\\r?\\n)*?.*\\((.*)\\)";
final String string = "ENTITY first\n"
+ " VHDL language standard: 3 (VHDL-2008)\n"
+ " ARCHITECTURE BODY arch\n"
+ " VHDL language standard: 3 (VHDL-2008)";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}