using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"ENTITY(?:.*\r?\n)*?.*\((.*)\)";
string input = @"ENTITY first
VHDL language standard: 3 (VHDL-2008)
ARCHITECTURE BODY arch
VHDL language standard: 3 (VHDL-2008)";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}