using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(The reason for this is\s*:\s*)([\s\S]*?)(\s*Kind regards)";
string input = @"The reason for this is: 111111111
2222
Kind regards.";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}