re = /(The reason for this is\s*:\s*)([\s\S]*?)(\s*Kind regards)/
str = 'The reason for this is: 111111111
2222
Kind regards.'
# Print the match result
str.match(re) do |match|
puts match.to_s
end