package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(The reason for this is\s*:\s*)([\s\S]*?)(\s*Kind regards)`)
var str = `The reason for this is: 111111111
2222
Kind regards.`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}