$re = '/(The reason for this is\s*:\s*)([\s\S]*?)(\s*Kind regards)/';
$str = 'The reason for this is: 111111111
2222
Kind regards.';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);