#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<\/h2>((?:\s|.)*)<h2"
Local $sString = "<h2>my title here</h2>" & @CRLF & _
"Lorem ipsum dolor sit amet" & @CRLF & _
"<h2>my title here</h2>" & @CRLF & _
"consectetur adipisicing elit quod tempora"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")