const regex = /<\/h2>((?:\s|.)*)<h2/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<\\\/h2>((?:\\s|.)*)<h2', '')
const str = `<h2>my title here</h2>
Lorem ipsum dolor sit amet
<h2>my title here</h2>
consectetur adipisicing elit quod tempora`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}