import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<\\/h2>((?:\\s|.)*)<h2";
final String string = "<h2>my title here</h2>\n"
+ "Lorem ipsum dolor sit amet\n"
+ "<h2>my title here</h2>\n"
+ "consectetur adipisicing elit quod tempora";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}