re = /<\/h2>((?:\s|.)*)<h2/
str = '<h2>my title here</h2>
Lorem ipsum dolor sit amet
<h2>my title here</h2>
consectetur adipisicing elit quod tempora'
# Print the match result
str.match(re) do |match|
puts match.to_s
end