$re = '/^(CP-([0-9A-Z]{1,6})-SEP([0-9A-F]{12}))$/';
$str = 'CP-8961-SEP1CAA07E2C8DE';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);