import Foundation
let pattern = #"^(CP-([0-9A-Z]{1,6})-SEP([0-9A-F]{12}))$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"CP-8961-SEP1CAA07E2C8DE"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}