#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?: |\G)\d\B\K"
Local $sString = "123 a123 1234567 b123 123"
Local $sSubst = "*"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)