use strict;
my $str = '123 a123 1234567 b123 123';
my $regex = qr/(?: |\G)\d\B\K/p;
my $subst = '*';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";