using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?: |\G)\d\B\K";
string substitution = @"*";
string input = @"123 a123 1234567 b123 123";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}