import Foundation
let pattern = #"(?: |\G)\d\B\K"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"123 a123 1234567 b123 123"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"*"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)