const regex = new RegExp('^[^a-z]+', 'gi')
const str = `90+3' SGDGG p[gdsg] sadgcgbcvb`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);