use strict;
my $str = '90+3\' SGDGG p[gdsg] sadgcgbcvb';
my $regex = qr~^[^a-z]+~ip;
my $subst = '';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";