#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)sans-serif; color:black\">(.?)"
Local $sString = "age email" & @CRLF & _
"33 </style></head><body lang="EN-IN"link="#0563C1" vlink="#954F72">. " & @CRLF & _
" <divclass="WordSection1"><p class="MsoNormal"><spanstyle="font- " & @CRLF & _
" family:"Calibri",sans-serif; color:black">Iam not interested. " & @CRLF & _
" Please unsubscribe me. </span></p><pclass="MsoNormal">" & @CRLF & _
" <spanstyle="font-family:"Calibri",sans-serif;color:black"> " & @CRLF & _
"" & @CRLF & _
"22 </style></head><body lang="EN-IN"link="#0563C1" vlink="#954F72"> " & @CRLF & _
" <divclass="WordSection1"><p class="MsoNormal"><spanstyle="font- " & @CRLF & _
" family:"Calibri",sans-serif;color:black">Please share company " & @CRLF & _
" details</span></p><divclass="MsoNormal" align="center"style="text- " & @CRLF & _
" align:center"><hr size="2"width="98%" align="center"></div> " & @CRLF & _
" <pclass="MsoNormal">" & @CRLF & _
"" & @CRLF & _
"43 </style></head><body lang="EN-IN"link="#0563C1" vlink="#954F72"> " & @CRLF & _
" <divclass="WordSection1"><p class="MsoNormal"><spanstyle="font- " & @CRLF & _
" family:"Calibri",sans-serif;color:black">Can you send " & @CRLF & _
" some project info for west region ofIndia</span></p><p class="MsoNormal"> " & @CRLF & _
" <spanstyle="font-family:"Calibri",sans-serif;color:black">" & @CRLF & _
"" & @CRLF & _
"38 </style></head><bodylang="EN-IN" link="#0563C1"vlink="#954F72"><div " & @CRLF & _
" class="WordSection1"><pclass="MsoNormal"><span style="font- " & @CRLF & _
" family:"Calibri",sans-serif;color:black">Price of Mono perc</span> " & @CRLF & _
" </p><divclass="MsoNormal" align="center"style="text-align:center"><hr " & @CRLF & _
" size="2"width="98%" align="center"></div><pclass="MsoNormal"><b>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")