import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "sans-serif; color:black\\\">(.?)";
final String string = "age email\n"
+ "33 </style></head><body lang=\"EN-IN\"link=\"#0563C1\" vlink=\"#954F72\">. \n"
+ " <divclass=\"WordSection1\"><p class=\"MsoNormal\"><spanstyle=\"font- \n"
+ " family:"Calibri",sans-serif; color:black\">Iam not interested. \n"
+ " Please unsubscribe me. </span></p><pclass=\"MsoNormal\">\n"
+ " <spanstyle=\"font-family:"Calibri",sans-serif;color:black\"> \n\n"
+ "22 </style></head><body lang=\"EN-IN\"link=\"#0563C1\" vlink=\"#954F72\"> \n"
+ " <divclass=\"WordSection1\"><p class=\"MsoNormal\"><spanstyle=\"font- \n"
+ " family:"Calibri",sans-serif;color:black\">Please share company \n"
+ " details</span></p><divclass=\"MsoNormal\" align=\"center\"style=\"text- \n"
+ " align:center\"><hr size=\"2\"width=\"98%\" align=\"center\"></div> \n"
+ " <pclass=\"MsoNormal\">\n\n"
+ "43 </style></head><body lang=\"EN-IN\"link=\"#0563C1\" vlink=\"#954F72\"> \n"
+ " <divclass=\"WordSection1\"><p class=\"MsoNormal\"><spanstyle=\"font- \n"
+ " family:"Calibri",sans-serif;color:black\">Can you send \n"
+ " some project info for west region ofIndia</span></p><p class=\"MsoNormal\"> \n"
+ " <spanstyle=\"font-family:"Calibri",sans-serif;color:black\">\n\n"
+ "38 </style></head><bodylang=\"EN-IN\" link=\"#0563C1\"vlink=\"#954F72\"><div \n"
+ " class=\"WordSection1\"><pclass=\"MsoNormal\"><span style=\"font- \n"
+ " family:"Calibri",sans-serif;color:black\">Price of Mono perc</span> \n"
+ " </p><divclass=\"MsoNormal\" align=\"center\"style=\"text-align:center\"><hr \n"
+ " size=\"2\"width=\"98%\" align=\"center\"></div><pclass=\"MsoNormal\"><b>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}