import Foundation
let pattern = #"sans-serif; color:black\">(.?)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
age email
33 </style></head><body lang="EN-IN"link="#0563C1" vlink="#954F72">.
<divclass="WordSection1"><p class="MsoNormal"><spanstyle="font-
family:"Calibri",sans-serif; color:black">Iam not interested.
Please unsubscribe me. </span></p><pclass="MsoNormal">
<spanstyle="font-family:"Calibri",sans-serif;color:black">
22 </style></head><body lang="EN-IN"link="#0563C1" vlink="#954F72">
<divclass="WordSection1"><p class="MsoNormal"><spanstyle="font-
family:"Calibri",sans-serif;color:black">Please share company
details</span></p><divclass="MsoNormal" align="center"style="text-
align:center"><hr size="2"width="98%" align="center"></div>
<pclass="MsoNormal">
43 </style></head><body lang="EN-IN"link="#0563C1" vlink="#954F72">
<divclass="WordSection1"><p class="MsoNormal"><spanstyle="font-
family:"Calibri",sans-serif;color:black">Can you send
some project info for west region ofIndia</span></p><p class="MsoNormal">
<spanstyle="font-family:"Calibri",sans-serif;color:black">
38 </style></head><bodylang="EN-IN" link="#0563C1"vlink="#954F72"><div
class="WordSection1"><pclass="MsoNormal"><span style="font-
family:"Calibri",sans-serif;color:black">Price of Mono perc</span>
</p><divclass="MsoNormal" align="center"style="text-align:center"><hr
size="2"width="98%" align="center"></div><pclass="MsoNormal"><b>
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)