import re
regex = re.compile(r"sans-serif; color:black\">(.?)", flags=re.MULTILINE)
test_str = ("age email\n"
"33 </style></head><body lang=\"EN-IN\"link=\"#0563C1\" vlink=\"#954F72\">. \n"
" <divclass=\"WordSection1\"><p class=\"MsoNormal\"><spanstyle=\"font- \n"
" family:"Calibri",sans-serif; color:black\">Iam not interested. \n"
" Please unsubscribe me. </span></p><pclass=\"MsoNormal\">\n"
" <spanstyle=\"font-family:"Calibri",sans-serif;color:black\"> \n\n"
"22 </style></head><body lang=\"EN-IN\"link=\"#0563C1\" vlink=\"#954F72\"> \n"
" <divclass=\"WordSection1\"><p class=\"MsoNormal\"><spanstyle=\"font- \n"
" family:"Calibri",sans-serif;color:black\">Please share company \n"
" details</span></p><divclass=\"MsoNormal\" align=\"center\"style=\"text- \n"
" align:center\"><hr size=\"2\"width=\"98%\" align=\"center\"></div> \n"
" <pclass=\"MsoNormal\">\n\n"
"43 </style></head><body lang=\"EN-IN\"link=\"#0563C1\" vlink=\"#954F72\"> \n"
" <divclass=\"WordSection1\"><p class=\"MsoNormal\"><spanstyle=\"font- \n"
" family:"Calibri",sans-serif;color:black\">Can you send \n"
" some project info for west region ofIndia</span></p><p class=\"MsoNormal\"> \n"
" <spanstyle=\"font-family:"Calibri",sans-serif;color:black\">\n\n"
"38 </style></head><bodylang=\"EN-IN\" link=\"#0563C1\"vlink=\"#954F72\"><div \n"
" class=\"WordSection1\"><pclass=\"MsoNormal\"><span style=\"font- \n"
" family:"Calibri",sans-serif;color:black\">Price of Mono perc</span> \n"
" </p><divclass=\"MsoNormal\" align=\"center\"style=\"text-align:center\"><hr \n"
" size=\"2\"width=\"98%\" align=\"center\"></div><pclass=\"MsoNormal\"><b>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")