using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=class="")(?:([-\w]+) (?=\1[ ""]))+";
string substitution = @"";
string input = @"<li class=""active active active"">";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}