const regex = /(?<=class=")(?:([-\w]+) (?=\1[ "]))+/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=class=")(?:([-\\w]+) (?=\\1[ "]))+', '')
const str = `<li class="active active active">`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);