re = /(?<=class=")(?:([-\w]+) (?=\1[ "]))+/
str = '<li class="active active active">'
subst = ''
result = str.sub(re, subst)
# Print the result of the substitution
puts result