$re = '/(?<=class=")(?:([-\w]+) (?=\1[ "]))+/';
$str = '<li class="active active active">';
$subst = "";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;