use strict;
my $str = '<li class="active active active">';
my $regex = qr/(?<=class=")(?:([-\w]+) (?=\1[ "]))+/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";