#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(X+)\W(X+)\W(X+)"
Local $sString = "XXX-XXX-XXX" & @CRLF & _
"XX=XXXX^XXX" & @CRLF & _
"XXXXX@XX.XX"
Local $sSubst = "(\1)(\2)(\3)"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)