const regex = /(X+)\W(X+)\W(X+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(X+)\\W(X+)\\W(X+)', 'gm')
const str = `XXX-XXX-XXX
XX=XXXX^XXX
XXXXX@XX.XX`;
const subst = `(\1)(\2)(\3)`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);