re = /(X+)\W(X+)\W(X+)/m
str = 'XXX-XXX-XXX
XX=XXXX^XXX
XXXXX@XX.XX'
subst = '(\\1)(\\2)(\\3)'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result