$re = '/(X+)\W(X+)\W(X+)/m';
$str = 'XXX-XXX-XXX
XX=XXXX^XXX
XXXXX@XX.XX';
$subst = "(\1)(\2)(\3)";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;