#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\|[ ]?(a|b|d|f|j|k|m)([ ]*\=[ ]*)((?![\r\n]+\|)[0-9a-zA-Z, \[\]:\|\r\n\t])+"
Local $sString = "{{TemplateX" & @CRLF & _
"| a =" & @CRLF & _
"Foo bar" & @CRLF & _
"Blah blah" & @CRLF & _
"" & @CRLF & _
"Fizbin foo" & @CRLF & _
"" & @CRLF & _
"Ipsum lorem" & @CRLF & _
"|b =1" & @CRLF & _
"|c = 0fillertext" & @CRLF & _
"|d = 1alphabet" & @CRLF & _
"| e =" & @CRLF & _
"| f = 10: One " & @CRLF & _
"Hobbit" & @CRLF & _
"| g = aaaa, bbbb," & @CRLF & _
"" & @CRLF & _
" cccc," & @CRLF & _
"" & @CRLF & _
" dddd" & @CRLF & _
"|h = 15000" & @CRLF & _
"|i = -15000" & @CRLF & _
"| j = Level 4 [[domain:filk|Songs]]" & @CRLF & _
"| k =7 fizbin, 8 [[domain:trekkies|Shatners]]" & @CRLF & _
"|l = " & @CRLF & _
"|m = " & @CRLF & _
"}}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")