import re
regex = re.compile(r"\|[ ]?(a|b|d|f|j|k|m)([ ]*\=[ ]*)((?![\r\n]+\|)[0-9a-zA-Z, \[\]:\|\r\n\t])+")
test_str = ("{{TemplateX\n"
"| a =\n"
"Foo bar\n"
"Blah blah\n\n"
"Fizbin foo\n\n"
"Ipsum lorem\n"
"|b =1\n"
"|c = 0fillertext\n"
"|d = 1alphabet\n"
"| e =\n"
"| f = 10: One \n"
"Hobbit\n"
"| g = aaaa, bbbb,\n\n"
" cccc,\n\n"
" dddd\n"
"|h = 15000\n"
"|i = -15000\n"
"| j = Level 4 [[domain:filk|Songs]]\n"
"| k =7 fizbin, 8 [[domain:trekkies|Shatners]]\n"
"|l = \n"
"|m = \n"
"}}")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")