const regex = /\|[ ]?(a|b|d|f|j|k|m)([ ]*\=[ ]*)((?![\r\n]+\|)[0-9a-zA-Z, \[\]:\|\r\n\t])+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\|[ ]?(a|b|d|f|j|k|m)([ ]*\\=[ ]*)((?![\\r\\n]+\\|)[0-9a-zA-Z, \\[\\]:\\|\\r\\n\\t])+', 'g')
const str = `{{TemplateX
| a =
Foo bar
Blah blah
Fizbin foo
Ipsum lorem
|b =1
|c = 0fillertext
|d = 1alphabet
| e =
| f = 10: One
Hobbit
| g = aaaa, bbbb,
cccc,
dddd
|h = 15000
|i = -15000
| j = Level 4 [[domain:filk|Songs]]
| k =7 fizbin, 8 [[domain:trekkies|Shatners]]
|l =
|m =
}}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}