import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\|[ ]?(a|b|d|f|j|k|m)([ ]*\\=[ ]*)((?![\\r\\n]+\\|)[0-9a-zA-Z, \\[\\]:\\|\\r\\n\\t])+";
final String string = "{{TemplateX\n"
+ "| a =\n"
+ "Foo bar\n"
+ "Blah blah\n\n"
+ "Fizbin foo\n\n"
+ "Ipsum lorem\n"
+ "|b =1\n"
+ "|c = 0fillertext\n"
+ "|d = 1alphabet\n"
+ "| e =\n"
+ "| f = 10: One \n"
+ "Hobbit\n"
+ "| g = aaaa, bbbb,\n\n"
+ " cccc,\n\n"
+ " dddd\n"
+ "|h = 15000\n"
+ "|i = -15000\n"
+ "| j = Level 4 [[domain:filk|Songs]]\n"
+ "| k =7 fizbin, 8 [[domain:trekkies|Shatners]]\n"
+ "|l = \n"
+ "|m = \n"
+ "}}";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}