#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)Idioma\s(?>\P{M}\p{M}*)\s:\s(?>\P{M}\p{M}*)\s[a-zA-Zñ]*"
Local $sString = "ASIN : B09RLXVHSB Editorial : Independently published (30 enero 2022) Idioma : Español Tapa blanda : 102 páginas ISBN-13 : 979-8410369077 Edad de lectura : De 1 a 12 años Peso del producto : 327 g Dimensiones : 21.59 x 0.58 x 27.94 cm"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")