using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Idioma\s(?>\P{M}\p{M}*)\s:\s(?>\P{M}\p{M}*)\s[a-zA-Zñ]*";
string input = @"ASIN : B09RLXVHSB Editorial : Independently published (30 enero 2022) Idioma : Español Tapa blanda : 102 páginas ISBN-13 : 979-8410369077 Edad de lectura : De 1 a 12 años Peso del producto : 327 g Dimensiones : 21.59 x 0.58 x 27.94 cm";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}