re = /Idioma\s(?>\P{M}\p{M}*)\s:\s(?>\P{M}\p{M}*)\s[a-zA-Zñ]*/m
str = 'ASIN : B09RLXVHSB Editorial : Independently published (30 enero 2022) Idioma : Español Tapa blanda : 102 páginas ISBN-13 : 979-8410369077 Edad de lectura : De 1 a 12 años Peso del producto : 327 g Dimensiones : 21.59 x 0.58 x 27.94 cm'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end