import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Idioma\\s(?>\\P{M}\\p{M}*)\\s:\\s(?>\\P{M}\\p{M}*)\\s[a-zA-Zñ]*";
final String string = "ASIN : B09RLXVHSB Editorial : Independently published (30 enero 2022) Idioma : Español Tapa blanda : 102 páginas ISBN-13 : 979-8410369077 Edad de lectura : De 1 a 12 años Peso del producto : 327 g Dimensiones : 21.59 x 0.58 x 27.94 cm";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}