import re
regex = re.compile(r"Idioma\s(?>\P{M}\p{M}*)\s:\s(?>\P{M}\p{M}*)\s[a-zA-Zñ]*", flags=re.MULTILINE)
test_str = "ASIN : B09RLXVHSB Editorial : Independently published (30 enero 2022) Idioma : Español Tapa blanda : 102 páginas ISBN-13 : 979-8410369077 Edad de lectura : De 1 a 12 años Peso del producto : 327 g Dimensiones : 21.59 x 0.58 x 27.94 cm"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")