import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b[\\w\\.-]+@((?!gmail|yahoo|hotmail).)[\\w\\.-]+\\.\\w{2,7}\\b\n";
final String string = "asdfas@hotmail.com\n"
+ "gdfa@gmail.com\n"
+ "edenp@techday.com\n"
+ "asdfasdf@dasfdas.dofdfdf\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}