#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)((?:[^ ]|[^ ] [^ ])+)(?: +|$)"
Local $sString = "aaaaa" & @CRLF & _
"aa aa a" & @CRLF & _
"aaa aaa" & @CRLF & _
"aa aa aaa" & @CRLF & _
"aaaa aaa" & @CRLF & _
"aa aa aa aa aa a" & @CRLF & _
"field1 field 2 field 3"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")